<div dir="ltr">I have some suggestions.  They are no more than shots in the dark, but hey.<div><br></div><div>1. Re-verify your Known Information.  Make sure it is really true.</div><div><br></div><div>2. Measure the voltage across a magnet when it is active but should not be.  There is some, right?  Disconnect things until there is no voltage across that magnet.</div>
<div><br></div><div>3. You say (#5) that you can change the power wiring to the magnets.  Can you measure voltage coming out of the power supply to the incorrectly active magnet?  If you unplug that magnet from power, what happens?  if you unpower its twin, what happens?</div>
<div><br></div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Thu, Aug 22, 2013 at 6:45 PM, Cord Slatton <span dir="ltr"><<a href="mailto:cord42@gmail.com" target="_blank">cord42@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">Hello All!<div><br></div><div>I have a device that I can only say so much about due to an NDA but I am having a problem with and need a bit of advice. If I have not given enough info or a diagram (though I cannot be too detailed on certain aspects) is needed, please let me know.</div>

<div><br></div><div>Thanks so much!</div><div><br></div><div>------------------------------------------------------------------------------------------------------</div><div>I have Arduino based controller that turns on a single control board input, which turns on one of 4 individual mosfet banks. When a mosfet bank is on it allows current to flow which turns on an electromagnet.</div>

<div><br></div><div>The magnets are hooked to the main power bus, all the same way, one side going to positive and one to negative with a mosfet bank keeping it from being always on.</div><div><br></div><div>There is a bit of something in the magnet connector that is supposed to cancel backflow EMF that could damage the controller, I am not positive what is going on with that but it is super simple part wise, and I can get the part number and post it if needed.</div>

<div><br></div><div>This system used to work correctly in the past the way it is wired, but not when I had it in my possession.</div><div><br></div><div><div style="font-family:arial,sans-serif;font-size:13px">Problem: When a magnet is activated another magnet is always active at the same time.</div>

<div style="font-family:arial,sans-serif;font-size:13px"><br></div><div style="font-family:arial,sans-serif;font-size:13px">Known Information</div><div style="font-family:arial,sans-serif;font-size:13px"><ol><li style="margin-left:15px">

The Arduino controller and the control board are working correctly. It sends a pulse to the correct mosfet bank. The correct indicator light activates and high voltage is sent to the corresponding mosfet bank.</li><li style="margin-left:15px">

The mosfet banks seem to be working correctly, only the one receiving a signal activates.</li><li style="margin-left:15px">The magnet that is triggered by the controller does activate(correct behavior).</li><li style="margin-left:15px">

The incorrectly triggering magnet is not triggered through induction and proximity does not matter.</li><li style="margin-left:15px">The same pairs of magnets always activate, even if rewired to the power supply in different configurations(magnets 1 & 4, 2 & 3)</li>

<li style="margin-left:15px">The only way to get a single magnet to activate is to remove it's paired magnet from the machine.</li><li style="margin-left:15px">The Arduino based controller I built is connected thusly: a ground wire to share the circuit's common ground and 4 control wires, each to individually turn on the pins on the device control board that drive the mosfets.</li>

<li style="margin-left:15px">Changing out the Arduino based controller for another control method(or manual control) does not change the behavior of the machine</li></ol><div>--------------------------------------------------------------------------------------------------</div>

</div></div></div>
<br>_______________________________________________<br>
Discuss mailing list<br>
<a href="mailto:Discuss@eugenemakerspace.com">Discuss@eugenemakerspace.com</a><br>
<a href="http://eugenemakerspace.com/mailman/listinfo/com.eugenemakerspace.discuss" target="_blank">http://eugenemakerspace.com/mailman/listinfo/com.eugenemakerspace.discuss</a><br>
<br></blockquote></div><br><br clear="all"><div><br></div>-- <br>Bob Miller                              K<bob><br>                                        <a href="mailto:kbob@jogger-egg.com">kbob@jogger-egg.com</a><br>

</div>